Nodemailer v2.0 released

Nodemailer v2.0 is now officially released.

Install it with:

npm install nodemailer --save

Changes compared to previous versions

  • SMTP support is now completely bundled (including direct and pool based sending) into Nodemailer and no additional plugins are required to use these. You can even use connection urls like these for easier configuration management:
    • var conf = "smtps://user:[email protected]?pool=true"
    • var conf = "direct:?"
  • All dependencies are completely locked, so no ^ or ~ version selectors anymore. This should ensure that in case there’s something wrong with Nodemailer you can safely downgrade to a previous version that you know that should work.
  • Logging got an overhaul. Instead of emitting ‘log’ events, Nodemailer takes a logger option which could be a bunyan compatible logger instance (Nodemailer uses debug, info and error calls)
  • Stream errors are not silently swallowed anymore. If you set an HTTP URL as an attachment and Nodemailer fails to fetch this URL, then sending is aborted and the resulting error is returned with the callback. Previous behavior was to ignore the error and append the error message to the attachment content
  • Full emoji support ?! Any string values, including attachment file names can include emojis ?
  • format=flowed is not used anymore when generating plaintext mime parts. This still caused issues with some clients even though the standard is from the nineties
  • Not visible to users but Nodemailer now uses ESLint instead of jshint to weed out any code issues

Leave a Reply

Your email address will not be published. Required fields are marked *